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Release Notes:
EFILive V8
Enhancements:
PR

Added Run Mode/Boot Mode/Unknown Mode status display for Cummins HD
controllers on [F4: OBD].
Reduced screen flicker when closing editor tab pages.
Added *.cax8 editing support for E55, E69 and E77.
Added editing support for E40.
Added editing support for E20.
Added editing support for E86A and E86B.

RC5

When changing the PID selections for scan tool maps, all three options (Data, Column
and Row) PID selection menus now appear in the right-click context menu regardless
of where the right-click occurs. Previously you were required to click on the map title
to select the data PID, or the col/row axis labels to select the col/row PIDs.
Added VE table units selection in Edit -> Properties -> Tuning Tool -> Settings.
Changes are displayed in real-time, no need to close/re-open the tune file when
changing units.
 WARNING: Undo/redo information is discarded for all open VE tables if/when the VE
display units are changed, which means changes to VE tables cannot be
undone/redone after changing the VE display units.

RC4

The [Check firmware] option for V3 devices now advises the user that "Some
firmware updates also contain a boot block update. After a firmware update, please
check the device's screen for a possible boot block update".
In the tune editor, the mouse scroll wheel now scrolls the data table if the data table
does not fit vertically on the screen. Previously the mouse scroll wheel only
controlled the 3D zoom level. Now, to control the 3D zoom level using the mouse
wheel, hold the Ctrl key down while scrolling the mouse wheel. 
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Added three new script functions for manipulating calibrations:
 (see EFILive Command Line Reference.pdf for more info)

efiGetCalInterp() which retrieves interpolated values from a calibration.1.
efiGetColPos() which retrieves the column position for use with the2.
_efiGetCalInterp() function.
efiGetrowPos() which retrives the row position for use with the3.
_efiGetCalInterp() function.

Updated the _efiGetCalValue() function to allow row and column text labels for
calibrations that use text labels in their axis.
New warning is now visible when alternate calibration data is being interpolated due
to axis differences between the main and alternate calibrations. 
New Copy/Paste option to optionally allow copying/pasting of calibration enumerated
text values instead of just the underlying numerical data.

RC3

None.

RC2

Copy to clipboard is now supported for copying selected text from the calibration
descriptions.
Merged the DTC codes and DTC MIL tables into a single composite table for LS1,
E54/E60, E37/E38/E67 controllers.
When creating *.cax8 files, you may now reference EFILive provided axis calibrations
without re-defining them in your *.cax8 file. EFILive will first search for the axis
calibration in the the *.cax8 file's Unique ID name-space, if not found, it will then
search in EFILive's default name-space.
When running updates from the [Compare] tab page, any mis-defined calibration
that results in calibration values of NAN (Not A Number) will not be updated from the
ALT to the CAL calibration.
Warnings are now displayed if/when calibrations cannot be updated due to NAN or
range errors. A text report of all failed and interpolated updates is now displayed at
the end of the update process.
LBZ/LMM (E35A/E35B) DTCs are now displayed correctly.

RC1

Changed the tune tool editor's right-click paste menu heirarchy to be identical to the
V7 menu hierarchy.
Changed the way PIDs are inserted when clicking on the PIDs in the right hand panel
of the calculated PIDs editor. If a PID name (or the literal text "PID") is currently
highlighted, then the highlighted text is replaced with the selected PID. If not, then
the entire pid() function is inserted, e.g. pid("ECM.RPM").·The scan/tune linking now
automatically converts between PID units and tune table axis units that are both



metric but not identical, (for example kPa and MPa) .
The scan/tune linking now automatically converts between PID units and tune table
axis units that are both metric but not identical, (for example kPa and MPa) .
Updated firmware re-programming routines to handle transitions into and out of
dead-poll mode more seamlessly.
Script conversion from V7 to V8 now generates scripts with more robust error
reporting.
The Ctrl+Alt+X "Reload cax8 files" option, now reports how many and which *.cax8
files were reloaded.
Added [F3: Tune] -> [F9: Scripting] -> [Create] option to create a script file based on
the differences between two tune files.
Added right-click context menu to script editor windows that includes Find and
Find/Replace options, along with the usual cut/copy/paste options.

Beta 52

Added a warning that displays before V7 script files are converted to their V8 Lua
script equivalents. the warning explains that the user is responsible for converting
non-metric units used in the V7 scripts to their metric equivalent in the V8 Lua script.
Converted the V7 script files for initializing DSP2 and DSP5 custom operating system
data to their V8 Lua script equivalents.
The [F3: Tune] -> [F5: Edit] -> [Convert] -> [Create New Table] button now supports
creating tables from clipboard data that has no label information. Labels are
generated automatically from 1..n to fit the data being pasted.
Two new clipboard formats for table data are now supported:
1. V7 script file data tables.
2. V8 Lua script file data tables.
You may now copy and paste those data tables from their scripts into any calibration
table.
The copy to clipboard option now has a new option to "Copy as Lua Source" which
will copy the selected data, formatted as a table in Lua source code. That table can
be pasted directly into EFILive Lua scripts.

Beta 51

The warning message displayed prior to running a script from the [F3: tune] -> [F9:
Scripting] tab page may now be hidden if required.
When loading multiple *.cax8 files, the software no longer stops loading additional
files after the first error. Now, all *.cax8 files are attempted to be loaded. If errors are
detected, a list of filenames, line numbers and error messages will be displayed to
the user.
When comparing two tune files, if all edit tab pages were closed then the tool bar
button to display the [Compare] tab page was incorrectly being disabled.



Added Properties -> Tuning Editor -> Editor -> "Allow Cax8 in OS Memory" option to
allow cax8 calibrations to be defined in the operating system memory for the
following controllers only: LS1A, LS1B, P10, P12, L31, P08, P11, T42, T43, T76, T87,
AL5, A40 and A50.

Beta 50

Added "UniqueID" option when using cax->cax8 conversions to allow a unique ID to
be added to the converted cax8 file. That unique ID is used to prefix calibration and
axis names to help mitigate naming conflicts between third party calibration
providers.
Updated the calibration search option to allow searching of calibration names without
needing to specify the prefix. Place the @ symbol before any single search word to
search only for calibrations with that name. For example, to search for calibrations
named SparkHigh, use @SparkHigh, that will find all calibrations with the name
SparkHigh, regardless of any unique ID prefix.

Beta 49

Updated E41 DMA PIDs.
For each calibration provider details are now shown in a new tab page called
[Provider]. That allows users to determine if a calibration is provided by EFILive or is
provided via a third party *.cax8 file.
Multiple *.cax8 files can now be loaded for each controller's operating system. Just
name the additional *.cax8 files with the OS number followed by an underscore then
a unique suffix, like this: 12345678_suffix1.cax8, 12345678_suffix2.cax8,
12345678_suffix3.cax8, etc.

Beta 48-7

Torque table validations are now included in the V8 tune editor.

Beta 48-6

Updated PID selections for AL5 controller.
[F4: OBD]-[DTC] now displays permanent DTCs alongside the usual current and
pending DTCs.
Added screen capture options to the tune tool editor.
[F5: BBX]->[Quick Setup] will now display any device settings from the current *.bbx
file when editing device settings via the [Edit ... Settings] button and the drop down
menu options.
[F6: Device Settings] can now open *.bbx files to extract and display any device
settings contained in the *.bbx file.
Added additional information to *.cax -> *.cax8 conversion process to help pinpoint
conversion issues in the original *.cax file.



Beta 48 (4)

When an AutoCal configured to self-sign reads either an E54 (LB7) or an E60 (LLY)
controller, the tune file is now self-signed with the correct serial numbers.
The "Clear DTCs" procedure at the end of the read/flash operation has been updated.
Save/Save As are now enabled by default in the [F6: Devices] tab page after reading
the device settings from a FlashScan or AutoCal device.
Cummins HD pass-thru data logging would log corrupt data if invalid PIDs were
selected.
Cummins HD pass-thru data logging would always fail to start with "no controllers
detected" error.

Beta 48 (3)

Replaced USBView.exe utility with the more comprehensive USBTreeView.exe in the
Drivers\Utilities folder.

Beta 48

TCM licensing is now free for both V2 and V3 devices.
FlashScan/AutoCal V3 VIN license slot count has been increased from 221 to 600.
Scan, tune and other windows can now be managed more easily via the Windows
Task Bar - or via new drop down button menus in the lower left corner, or via
hotkeys.
Software registration is not required.
Manage customer details per vehicle and use customer details in scan and tune file
name templates.
User defined calibrations conversion process from V7 *.cax file format to V8 *.cax8
format.
User defined script conversion process from V7 *.txt format to V8 *.Lua format.
V3 devices can be configured to appear as a USB thumb drive in Windows Explorer,
allowing file transfers and management to be performed without installing the
EFILive software.
Tune file editor is available for selected controllers and operating systems:
Tune file comparison between different operating systems.
Scan and tune file linking is now supported.
V3 devices support black box data logging without upgrading to CSP5.
Dodge Cummins FAST CAN mode can be configured as a device setting.
Custom, user defined menu systems can be created for V3 devices.
The EFILive EULA is displayed and must be accepted each time a V3 device is
powered on before it can be used in standalone mode.
AutoCal's linked/unlinked status is displayed at the bottom of the EULA screen.
Transferring files to/from V3 devices is up to 10 times faster than V2 devices.
And many more...



Bug Fixes:
RC6

Cummins HD CM2150 "Force All Checksums to be Correct" option was not working.
Added additional checks at the end of a Cummins HD flash to ensure reflash
completed successfully.
When comparing two tune files, displaying VE table alternate values was not possible
if the VE units had been changed from the default g*K/kPa units to % or g/cyl or
g/sec.
After closing the scan tool gauge property editor, attempting to resize the scan tool
window causes an access violation.
Font selection dialog box was incorrectly dragging the EFILive main window to the
front when activated, obscuring the window containing the component(s) being
edited.
Fixed font size selection problem in the font selection dialog box.
Added missing icons on OK/Cancel button in the font selection dialog box.

RC5

Changes to the CMF flash script for more stable failed flash recovery.
Fixed P12 (IL5/L52) calibration fault that caused incorrect values to be stored for
some speedo calibrations for OS 12627884.
Transferring files from FlashScan/AutoCal V2 devices to the PC using EFILive Explorer
would fail with error code $0106. 
Fixed E98 DMA PIDs that were not displaying correct data.
Menu text for "Next Scan Window" and "Next Tune Window" was missing from the
drop-down menu of the Scan/Tune buttons in the lower-left corner of the main
window and sub-windows.
A/D voltages were not being captured/displayed when pass-thru logging with
FlashScan V2.

RC4

When opening a log file from the main V8 window, the two [Scan] and [Tune] buttons
in the lower left were being overwritten with text labels.
Comparing Diagnostic Trouble Codes (DTCs) between different operating systems
now works correctly.
Displaying ALT Diagnostic Trouble Codes (DTCs) when comparing different operating
systems now works correctly.

RC3

None.

RC2



If the most recently used Options.txt file cannot be loaded when opening the [F5:
BBX] window the window would fail to open.
If the most recently used Settings.dat file cannot be loaded when opening the [F6:
Devices] window the window would fail to open.
Hex values now display CAL and ALT values correctly depending on which calibration
is currently selected for display.
Hex values now display correctly in the [Compare] tab page.
Removed absolute/relative options for script generation, scripts are now only
generated using absolute values. Due to the potential for overlapping calibrations,
scripts generated using the "relative" option would apply relative updates multiple
times (as many times as a calibration is defined), causing unintended results.
When auto-generating scripts, calibration identifier names were being incorrectly
created with a dot in the name (between the Unique ID and the calibration name) if
the calibration was defined in a *.cax8 file that included a Unique ID.
Some list-based calibrations, such as DTCs and related OBDII enablers were not
displaying nor updating the correct data in the tune file.
Fixed a number of bugs and display issues when setting up axis labels for scan tool
maps.
User's default units preferences are now applied correctly when opening calibrations.

RC1

Fixed row axis labels for E38/E67 calibration G0901 that were not udpating after the
B9904 fan patch was applied.
Fixed failure caused by some USB configurations that fail to provide accurate USB
location ID information to the USB driver.
Read-Only calibrations are now strictly read-only in the V8 editor and cannot be
changed.
Changed the "Cax8 Reload" hotkey from Ctrl+Alt+O to Ctrl+Alt+X. The Ctrl+Alt+O
hotkey was already in use to decrease the calibration display precision.
The script function _efiGetRowAxis() was returning column labels instead of row
labels.

Beta 52

Some old V7 scripts used label 0 to reference a single column with the label "Value"
(or some other non-numeric label). In V7, that worked because "Value" is not a valid
number as was defaulting to 0 which matched the target label of 0 from the script.
V8 is stricter than V7 and treats 0 and "Value" as different labels. V8 has now been
updated so that when searching for a rectangle defined like this: "0,0,0,5000"
(left,top,right,bottom) on a single column table with a column label of "Value" and
row labels of RPM from 0..5000, the rectangle is now re-defined by V8 to be
"@1,0,@1,5000". I.e. column 1 (the first and only column) and rows 0rpm to



5000rpm - the same as what V7 would have used.

Beta 51

Updated EFILive_CmdLine.exe to support unique ID prefixes for identifying cax8
calibrations.
Updated EFILive_CmdLine.exe to support AutoCal and FlashScan V3 devices.
When working with multiple *.cax8 files, the Ctrl+Alt+O hot key was only reloading
the most recently opened *.cax8 file instead of loading all *.cax8 files for the current
tune file.
The provider's unique ID value is now validated to ensure it is a valid identifier. To be
valid it must begin with a letter or underscore and be followed by up to 29 additional
letters, digits or underscores. I.e. Blue, _Fast, Red04 are all examples of valid
identifiers. 4Square and Red Hot are invalid, 4Square does not begin with a letter or
underscore, Red Hot contains a space character.
Provider details are now updated correctly when multiple different providers are
sharing the same parameter list.

Beta 50

Fixed pass-thru and BBx reading and flashing error $0503 "Script file not valid".

Beta 49

Fixed calibration layout dimensions not being saved/restored correctly across
application restart.
Fixed cax8 descriptions not showing up if the EFILive supplied calibration description
file is missing.
Fixed some calibration descriptions not updating correctly when the user changes
the display units. I.e. The description "Pulses per kilometer" was not changing to
"Pulses per mile" when the user changed display units from pluses/km to pulses/mile.
Fixed [F8: Tools]->[F8: Error Code] lookup not displaying complete information for
error codes in the range $0300..$037F.
Fixed some CMB reflash attempts that were failing with $0301 (incorrect checksum).
Floating point PIDs' values are now displayed correctly in the Scan Tool.
Row-deposit composite-tables' address calculation is now handled correctly for all
rows, not just the first row.
Windows 10 automatically adds a read-only folder to the root folder of an SD Card
when the SD Card is connected to a Windows 10 PC/laptop. When that SD Card is re-
inserted into FlashScan V2, EFILive_Explorer hangs when attempting to display that
read-only folder.

Beta 48-7

Fixed pass-thu data logging not starting for some VPW based controllers.
Send clear DTC commands to all controllers on the CAN bus, not just emissions



related controllers at end of read/flash process.

Beta 48-6

Fixed EDA data logging that showed an incorrect value for main injection pulse time
when both pilot1 and pilot2 pulse times were non-zero.
OS numbers with more than 8 digits are no longer truncated to 8 digits when stored
as meta data in data log files.
When using BBR to read E83A or E83B controllers, the steam name "E83A" or "E83B"
is now correctly stored in the *.ctz file's meta data.
Using F10 and F11 to make the charts or gauges full-screen, no longer drags the
main V8 window to the foreground.
Curve fitting popup editor window no longer drags main V8 window to the
foreground.
Fixed E54(LB7) and E60(LLY) DSP5 tune selection PID. It now correctly displays the
selected DSP5 tune instead of the DSP switch voltage.
Serial wide band PID data is now logged from V3 devices correctly during pass-thru
logging.
*.cax -> *.cax8 conversions now correctly handle bit fields.
Right-click "More Info" option for PIDs showed "Unspecified error" on second and
subsequent invocations.

Beta 48 (3)

Updated OBD error codes and messages in the $0300..$03FF range.

Beta 48

Fixed CMC checksum issue.
E54 (LB7) and E60 (LLY) serial numbers are now shown in the [F4: OBD] window.
CMF VIN change is now supported in [F4: OBD]->[VIN Change].
Disabled hotkeys for editing tune files when no tune file is open and/or when no
*.cam file is present for the open tune file.
Additional USB message management to mitigate the $0101 error that may occur on
some USB configurations.
Tune files from A40 controllers that identify as "A46" can now be opened the V8
software.
Selecting the "Next Scan/Tune Window" (hotkey Alt+F2 and Alt+F3) would cause the
next window to be restored to its un-maximized size if it had been previously
maximized.

Calibration Updates:
Dodge Cummins

None.



Cummins Heavy Duty

New operating system support for CM2350A
New operating system support for CM2250 and CM2350A
New support and updates for CM2450A and CM2670.
Added V8 editing support for CM2150, CM2220, CM2250 and CM3250A.

GM Gas

Added V8 editing support for E40
Added V8 editing support for LS1A and LS1B.
Added V8 editing support for E37, E38 and E67.

GM Diesel

Added V8 editing support for E20,  E86A, and E86B.
Added V8 editing support for E54 (LB7) and E60 (LLY).
Added V8 editing support for E35A and E35B.

Known Issues:

When logging DMA PIDs (i.e. PIDs whose names end with "_M" or "_DMA"), if the
ignition is switched off for an extended period while data logging but data logging is
not terminated, then when the ignition is switched on again the data log
automatically continues. However, the DMA PIDs may no longer return valid data.
Workaround: EFILive recommends stopping the data log and restarting the data log
when switching off the ignition for extended periods.

EFILive V7.5
Calibration Updates:
Dodge Cummins

New support and updates to existing operating systems for the following controllers:
CMC, CME and CMF.

Cummins Heavy Duty

New operating systems for the following controllers: CM2250 and CM2350A
New support and updates to existing operating systems for the following controllers:
CM2350A.

GM Gas

New support and updates to existing operating systems for the following controllers:
E39, E78, E80, E82, E84 and E92.

GM Diesel

New support and updates to existing operating systems for the following controllers:



E98.

Transmission:

New support for the following controllers: T43, T76.

Enhancements:

None.

Bug Fixes:

None.

Known Issues:

None.

FlashScan/AutoCal V3
Enhancements:
RC3 (V3.00.056)

Recompiled code base with updated ARM tool chain. 

RC3 (V3.00.055)

None.

RC2 (V3.00.054)

Custom menu options for selecting PIDs can now be optionally configured to
automatically select a pre-defined PID list and/or automatically begin data logging or
monitoring.

RC1 (V3.00.053)

BCM flashing is now free and no longer requires a VIN license, the same as
transmission controllers.

Beta 51 (V3.00.051)

Added option Tune Tool -> F1: Tuning -> F4: Test OBD Network to test CAN J1979
and/or VPW (1x and 4x) vehicle networks for the presence of rogue modules that do
not respect bus silence. Rogue modules can interfere with the read/flash process.
Added power-up option to force the V3 device into thumb drive mode. To force the
V3 device into thumb drive mode hold down the [Up] key while powering up the
device - release the key once the splash screen is visible.
Added power-up option to load EFILive's standard menu even when a custom menu
is installed. To load the standard menu, hold down the [X] key while powering up the
device - release the key once the splash screen is visible.



Beta 50 (V3.00.049)

·Updated controller identification algorithms.

Beta 49 (V3.00.047)

Fixed Scan Tool -> F3: Scan Options -> F3: Onboard Modules which was reporting
the "boot mode" and "run mode" status of Cummins light duty controllers the wrong
way around.
Full control of user defined menus, icons, images and themes is now supported via
the user defined menu configuration. See the file \Documents\EFILive\V8\User
Defined Menus\SampleCustomMenu.txt for additional information.

Beta 48-7 (V3.00.046)

Fixed DMA PIDs logging as "N/A" for some controllers when black box logging.
Options -> F2: Trouble Codes -> F1: Display DTCs now displays permanent DTCs
alongside the usual current and pending DTCs.
Added option to record OBDII data from VPW or CAN bus to *.xalm file for analysis by
EFILive support.

Bug Fixes:
RC3 (V3.00.055)

Fixed black box data logging stalling at startup when large number of PIDs (>50
channels) are selected.
Fixed user defined splash screen image not displaying at power-up.
Fixed firmware updates failing on a very small percentage of PCs (requires a boot
block update to V3.00.005).
Fixed file corruption that may be caused by USB message retries when transferring
data to/from V3 using EFILive Explorer.
Fixed data logging stall caused by a div-by-zero fault when EXT.WO2EQRx is selected
and EXT.WO2LAMx is zero, i.e. when no wideband controller is connected.

RC2 (V3.00.054)

If the SD Card contained no files or folders (or only hidden files/folders), then the
Options -> F2: File System -> F1: Explore -> F1: Browse option would hang -requiring
a power cycle to recover.
Import/Export VIN licenses option was not validating correctly against the controller
type, which may result in multiple VIN slots being allocated to the same controller.

RC1 (V3.00.053)

User defined PIDs were not being loaded correctly from the user defined PIDs file
when starting black box logging.
Fixed external wide band data not being logged correctly during pass-thru logging



and not at all during black box logging.
Fixed DSP tune switching for VPW based controllers: E54 (LB7) and E60 (LLY).

Beta 51 (V3.00.051)

Fixed VIN license validation that was failing on some VIN licenses that had been
transferred from V2 AutoCals to V3 AutoCals.

Beta 50 (V3.00.049)

Fixed pass-thru and BBX reading and flashing error $0503 "Script file not valid".
When custom images are supplied with incorrect sizes the V3 device may crash
when rendering those images. The firmware now validates the image size and will
not attempt to draw images that have incorrect sizes.
- Icons must be 48x48 pixels.
- Splash and background images must be 240x320 pixels.

Beta 48-7 (V3.00.046)

Calculated PID names are now preserved in log files when black box logging.
Calculated PIDs are not displayed during black box logging but are now correctly
displayed when the log file is re-opened in the V8 software.

V3.00.045

Changed "Stream" to "Controller ID" in the "Record All Diags" output file.
OS, Controller and Remote information was not displaying for scan and/or tune files
on V3 devices when displayed in EFILive Explorer.
When black box logging, the PID selection was incorrect when one or more inactive
controllers existed prior to the controller/PIDs selected by the user.
OS number was not displayed correctly for some CSP5 operating systems.
Fixed "CSP4" spelling mistake in tune switch menu description.
Serial wide band PID data is now transmitted correctly from V3 devices correctly
during pass-thru logging.
Reading and Flashing now allow extra time for other modules on the CAN/VPW bus to
come back online before attempting to clear trouble codes.

V3.00.044

Fixed "Clear DTC" option not working on VPW based controllers.
When CVN Data or CVN History is not successfully retrieved from the controller a
more user-friendly message is now displayed - instead of error $0281 "No data
retrieved".
Word wrapping for different font sizes is now handled correctly so that some letters
at the start and/or end of lines are not truncated.

V3.00.043



To protect the integrity of files on the device, any attempt to read, modify or delete
any file or folder using EFILive_Explorer.exe while a black box operation (read, flash
or data logging) is in progress, will be rejected with the error $010C "Device is busy".
Update to ensure all TCM controllers do not require a VIN license to be flashed.

V3.00.042

E45 (LB7) and E60 (LLY) serial numbers are now shown on the V3 screen when
selecting: Diagnostics -> F1: Display Info -> F1: Display VIN/Info.

Known Issues:

None.

FlashScan/AutoCal V2
Enhancements:
RC2 (V2.07.166)

New operating system support.

RC2 (V2.07.165)

New operating system support.

RC2 (V2.07.164)

New operating system support.

Bug Fixes:
RC1 (V2.07.165)

Fixed Access Violation when using File->Save As... after reading a controller.

Beta 48-7 (V2.07.164)

Changed "Stream" to "Controller ID" in the "Record All Diags" output file.
OS number was not displayed correctly for some CSP5 operating systems.
LCD screen capture of some prompt messages are now allowed during pass-thru
operation. Specifically, to allow screen capture of controller licensing messages for
documentation purposes.

Beta 48 (3)

Update to ensure all TCM controllers do not require a VIN license to be flashed.

Known Issues:

None.

Documentation Updates

EFILive Command Line Reference.pdf.



EFILive Error Codes.pdf.
EFILive V8 Reference.pdf.
AutoCal V3 User Guide.pdf.

Knowledgebase Updates

None.


